Categories
ubuntu

Install GIMP 2.7 on Ubuntu

This tutorial will show you how to install GIMP 2.7 on Ubuntu Jaunty without affecting the default GIMP 2.6 install

sudo apt-get install ruby # needed by gegl
git clone git://git.gnome.org/babl
git clone git://git.gnome.org/gegl
cd babl
./autogen.sh
make
sudo make install
cd ../gegl
./autogen.sh
sudo make install
sudo apt-get install libjasper-dev # the jasper libs are required to provide JPEG2000 support in GIMP
cd ..
wget ftp://ftp.gimp.org/pub/gimp/v2.7/gimp-2.7.0.tar.bz2
tar jxvf gimp-2.7.0.tar.bz2
cd gimp-2.7.0
./configure --prefix=/opt/gimp-2.7
make
sudo make install

Now just create a file gimp-2.7 inside /usr/bin as follows:

#!/bin/sh

PATH=/opt/gimp-2.7/bin:$PATH
export PATH
LD_LIBRARY_PATH=/opt/gimp-2.7/lib
export LD_LIBRARY_PATH

/opt/gimp-2.7/bin/gimp-2.7 "[email protected]"

Run /usr/bin/gimp-2.7 πŸ™‚

1 reply on “Install GIMP 2.7 on Ubuntu”

cd deepin-software-center/src/ && ./[email protected]:~/deepin-software-center/src$ * Command proxy lisetn File ./deepin-software-center.py , line 35, in import detailView File /home/zero/deepin-software-center/src/detailView.py , line 33, in from dtk.ui.browser import WebViewImportError: No module named dtk.ui.browser ζ€ŽδΉˆθ§£ε†³οΌŸ

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.