Fix VMware Workstation Module compile error on Ubuntu/Debian Linux

# Become root
sudo -i

# Do a couple of pre-requisites
apt-get install build-essential
ln -s /usr/src/linux-headers-$(uname -r)/include/generated/uapi/linux/version.h /usr/src/linux-headers-$(uname -r)/include/linux/version.h

# Extract each of the VMware module packages

cd /usr/lib/vmware/modules/source
for file in *
do
tar xvf $file
done

# Fetch and apply patches required for this release...
wget http://communities.vmware.com/servlet/JiveServlet/download/2234875-108182/vmci.linux-3-8.patch
patch -p0 < vmci.linux-3-8.patch

# Put the VMware module source packages back together again
for file in *-only
do
tar cvf `basename $file -only`.tar $file
done
rm -rf *-only

# Tell VMware to rebuild the modules - can also just run the command "vmware" as root
vmware-modconfig --console --install-all